Home System Requirements

System Requirements

Online version system requirements:

  • The online version requires a stable* broadband internet connection, preferably 0.5 Mbit/s or better
  • Mac or PC computer
  • Internet browser with Adobe Flash plugin
  • Adobe Flash plugin version 10.0 or later (get latest version at http://get.adobe.com/flashplayer)

 

*WLAN or 3/4G networks with low signal strength should be avoided  

 

Before you start using the new online version of Cogmed Working Memory Training, follow the following steps. They will ensure that your system is optimised for running this web-based program.

1.  Run Windows update
2.  Update Adobe flash player
3.  Consider using Google Chrome as your web browser  

Cogmed
Cogmed